Motive 2.0 beta is Now Available

Check out the Release notes and the 2.0 Wiki

Motive Basics

From NaturalPoint Product Documentation Ver 1.10
Jump to: navigation, search
Back to the Main PageBack to Motive Documentation


Before diving into specific details, let’s begin with a brief overview of Motive. If you are new to using Motive, we recommend you read through this page and learn about the basic tools, configurations and navigation controls, as well as instructions on managing capture files. Understanding the topics covered on this page will help when using Motive. Also, some of Motive's more useful features are highlighted to help improve your mocap experience.


File Management[edit]



Motive file management video
Motive Project Pane
Windows File Explorer

The Project pane is the primary interface for managing capture files in Motive, and it can be accessed from the Tb9.png icon on the main toolbar, or under the View tab. This pane contains lists of capture files, trackable objects, and their corresponding properties. Motive will save and load Motive-specific file formats including the Take files (TAK), Project files (TTP), Calibration files (CAL), and asset definition files for skeletons and rigid bodies (SKL and TRA). The asset definition is related to trackable assets in Motive, and it will be explained more in the Rigid Body Tracking and Skeleton Tracking page.


Project File (TTP)

Always start a Motive Session with a Project File, either by creating a new project (File -> New Project) or loading an existing project (File -> Load Project). A project file establishes a root folder under which all subsequent data is stored. Multiple capture files are grouped into session folders and these folders are managed in a Project (TTP) file. Project files contain software settings and references to all aspects of a motion capture shoot, including the current camera calibration, session and take organization, default tracking models (assets), and any project specific settings. You can simply open the saved TTP file and access all of the subsequent files that are associated with the project. If accessing a certain project file is a regular workflow, you can also create a batch file to automate this.


Take File (TAK)

Motive file management is centered on the Take (TAK) file. A TAK file is a single motion capture recording (aka 'take' or 'trial'), which contains all the information necessary to recreate the entire capture from the file, including camera calibration, camera 2D data, reconstructed and labeled 3D data, data edits, solved joint angle data, tracking models (Skeletons, RigidBodies), and any additional device data (audio, force plate, etc). A Motive Take (TAK) file is a completely self-contained motion capture recording, and it can be opened by another version of Motive on another system.


Session Folders

A Session is a file folder that allows the user to organize multiple similar takes (e.g. Monday, Tuesday, Wednesday, or StaticTrials, WalkingTrials, RunningTrials, etc). Whether you are planning the day's shoot or incorporating a group of Takes mid-project, creating sessions folders can help manage complex sets of data. To create a new session, simply select the New Session button Createsession.png in the Project pane. For a most efficient workflow, plan the mocap session before the capture and organize a list of captures (shots) that need to be completed. Type Take names in a spreadsheet or a text file, and Copy and paste the list into project pane, which will automatically create empty Takes (shot list) with corresponding names from the pasted list.


Calibration files (CAL)

A calibration file is a standalone file that contains all required information to restore a calibrated camera volume, including the cameras used and their lense distortion parameters. This file is useful when the system setup (camera setup) has been kept constant, and can be automatically loaded at startup to provide instant access to the 3D volume. Read more from Calibration page.




Viewports[edit]



Tutorial Video: 2D and 3D views in Motive

In Motive, the main viewport is fixed at the center of the UI. This main View Pane is used to monitor either the 2D or 3D capture data in both live and edit mode. The Perspective View mode Viewport18.png displays the reconstructed 3D data in a 3D space, and the Camera Preview mode Viewport1.png shows 2D images from each camera in the setup. Both of these views are essential for assessing and monitoring the tracking data.


Perspective View - 3D viewport

  • Used to look through the reconstructed 3D representation of the capture, analyze marker positions, rays used in reconstruction, etc.
  • The context menu in the Perspective View allows you to access more options related to the markers and assets in 3D tracking data.


3D perspective view pane in Motive


Camera Preview - 2D view port

  • Each camera’s view can be accessed from the Camera Preview pane. It displays the images that are being transmitted from each camera. The image processing modes are displayed, including grayscale and object
  • Detected reflections are also shown in this pane, and reflections which satisfy the object filters and considered as markers
  • From Camera Preview pane, you can mask certain pixel regions to exclude them from the process.


Basics CameraPreview.png


Basic Navigation Controls[edit]



Most of the navigation features in Motive (1.9.0 and above) are customizable, including both mouse and Hotkey controls. The Hotkey Editor Pane and the Mouse Control Pane under the Edit tab allows you to customize mouse navigation and keyboard shortcuts to common operations.


View Port Mouse Control

Mouse Controls pane used to customize the navigation mouse controls.

Motive comes with a variety of common mouse control 'profiles'. Control profile presets include: Motive, Blade, Autodesk Maya, and Autodesk. You can also open the Mouse Control pane under the Edit tab in order to customize the setting for your own preference.


Function Default Control
Rotate view Right + Drag
Pan view Middle (wheel) click + drag
Zoom in/out Mouse Wheel
Select in View Left mouse click
Toggle Selection in View CTRL + left mouse click


Hotkeys

Using Hotkeys can improve the speed of workflows in Motive. All default hotkeys are listed in the Motive Hotkeys page. For Motive 1.9 and above, Hotkeys can be customized in the Hotkey Editor (shown below), which can be accessed under the Edit tab in the Main Tool Bar. Various actions can be assigned with a custom hotkey using the Hotkey Editor.

For a list of the default Hotkey settings, read through the Motive Hotkeys Page.

Basics Hotkey.png


Timeline[edit]



Tutorial: Timeline in Motive

The Timeline Pane provides control over Motive's two primary operating modes: Live and Edit. See also: Timeline Pane page.

Timeline pane in Motive.


Live Mode and Edit Mode


In the Live Mode, all cameras are active and the system is processing camera data. If the mocap system is already calibrated, Motive is live-reconstructing 2D camera data into labeled and unlabeled 3D trajectories (markers) in real-time. The live tracking data can be streamed to other applications using the data streaming tools or the NatNet SDK. Also, in Live mode, the system is ready for recording and corresponding capture controls will be available in the Timeline Pane.

In the Edit Mode, the cameras are not active, and Motive is processing loaded Take file (pre-recorded data). In Edit Mode, playback controls will be available in the timeline pane, including access to the frame scrubber and the 2D Graph Editor for accessing and editing 3D trajectory data.


  • Live mode.
  • Edit Mode.


Timeline Editor Navigation


Icon Name Description
Timeline Combined.png
Combined View Switches to the Combined View mode.
Timeline Channel.png
Channel View Switches to the Channel View mode.
Timeline Tracks.png
Tracks View Switches to the Tracks View mode.
Timeline X.png
Show X Channel Toggle to show/hide X trajectories on selected markers.
Timeline Y.png
Show Y Channel Toggle to show/hide Y trajectories on selected markers.
Timeline Z.png
Show Z Channel Toggle to show/hide Z trajectories on selected markers.
Timeline DrawKeys.png
Draw Keys Manual draw trajectory by clicking and dragging on a selected trajectory in the Editor.
Timeline Move.png
Move Selected Keys Translates trajectories in selected frame region. Select a range and drag up and down on a trajectory.
Timeline Delete.png
Delete Selected Keys Delete selected frame region.
Timeline Recenter.png
Recenter on frame

(selected range)

Zooms into selected frame region and centers the timeline accordingly
Timeline ZoomFit.png Recenter on frame Centers the timeline according to the current frame.
Timeline Autoscale.png
Autoscale Graph Toggle to autoscale X/Y/Z graphs
Timeline EditTools.png
Show Edit Tools Opens the Edit Tools pane for post-processing.

Select Marker(s) for Viewing/Editing

  • Click on a marker in the 3D Viewport or Marker Data List to set as the active marker in the Timeline. Control-click to select multiple markers, and shift-click to select a range of markers.
  • Double click on a marker from the Marker Data list to zoom to it in the 3D Viewport.


Change Active Frame or Select a Range of Frames

  • Left click and drag on the timeline graph to select an active range for zooming and looping during playback. (To loop playback within a selected range, you must first zoom into that selected range.)
  • Left click and drag on the playback bar to scrub through frames.
  • Lock the cursor to follow the cursor along the timeline graph, when playing data back within a cropped range of frames.


Frame the Timeline

  • Press "F" to zoom to the selected range on the timeline.
  • Press "Shift + F" to frame the complete timeline.
  • Manually select a range by entering the beginning and ending frames in the text boxes.
  • Middle click and drag on the timeline graph to pan the framed range forward and backward.
Middle Mouse Zoom


Zoom/Scale

  • Right-click and drag on the timeline graph to free-form zoom in and out. If Autoscale Graph is turned off, panning up and down will ajust vertical scaling for the X, Y, or Z channel.
  • Middle mouse-click and drag on the playback bar to select a range to zoom to, without changing your current selected range on the timeline graph:



Application Settings[edit]



The Application Settings can be accessed under the Edit tab or from the Tb4.png icon on the toolbar. This pane is used to modify preferences that are related to General, Views, Skeletons, and Rigid Bodies. Here, you can modify general settings such as startup configuration and display options for viewports. Also, default creation settings for newly created assets are configured under the Skeletons and Rigid Bodies tab. Many other software preferences can be modified from this pane, read and find more about available preference settings from the Application Settings Pane page. If you wish to reset the default application setting, go to Reset Application Settings under the Edit tab.


Layouts[edit]



The UI layout in Motive is customizable. All panes can be docked and undocked from the UI. Each pane can be positioned and organized by drag-and-drop using the on-screen docking indicators. Panes may float, dock, or stack. When stacked together, they form a tabbed window for quickly cycling through. Layouts in Motive can be saved and loaded, allowing a user to switch quickly between default and custom configurations suitable for different needs. Motive has preset layouts for Calibration, Creating a Skeleton, Capturing (Record), and Editing workflows. Custom layouts can be created, saved, and set as default from the Main Menu -> 'Layout' menu item. Quickly restore a particular layout from the Layout menu, the Layout Dropdown at the top right of the Main Menu, or via HotKeys.


  • Docking indicator
  • Motive layout options
  • Layout features overview.



Back: Motive Documentations

Next: Capture Setup